Uncontrolled Recursion

Affecting python-django package, versions <1.8.7-1ubuntu5.10

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream python-django package. See Remediation section below for Ubuntu:16.04 relevant versions.

An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x before 2.2.4. If passed certain inputs, django.utils.encoding.uri_to_iri could lead to significant memory usage due to a recursion when repercent-encoding invalid UTF-8 octet sequences.

Remediation

Upgrade Ubuntu:16.04 python-django to version 1.8.7-1ubuntu5.10 or higher.

References

CVSS Score

7.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE
CVE-2019-14235
CWE
CWE-674
Snyk ID
SNYK-UBUNTU1604-PYTHONDJANGO-456328
Disclosed
02 Aug, 2019
Published
01 Aug, 2019