Security Features

Affecting python-django package, versions <1.8.7-1ubuntu5.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream python-django package. See Remediation section below for Ubuntu:16.04 relevant versions.

The cookie parsing code in Django before 1.8.15 and 1.9.x before 1.9.10, when used on a site with Google Analytics, allows remote attackers to bypass an intended CSRF protection mechanism by setting arbitrary cookies.

Remediation

Upgrade Ubuntu:16.04 python-django to version 1.8.7-1ubuntu5.2 or higher.

References

CVSS Score

7.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVE
CVE-2016-7401
CWE
CWE-254
Snyk ID
SNYK-UBUNTU1604-PYTHONDJANGO-360883
Disclosed
03 Oct, 2016
Published
03 Oct, 2016