Buffer Overflow

Affecting python2.7 package, versions <2.7.12-1ubuntu0~16.04.18

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to Buffer Overflow. Python 3.x through 3.9.1 has a buffer overflow in PyCArg_repr in _ctypes/callproc.c, which may lead to remote code execution in certain Python applications that accept floating-point numbers as untrusted input, as demonstrated by a 1e300 argument to c_double.from_param. This occurs because sprintf is used unsafely.

Remediation

Upgrade python2.7 to version or higher.

References

CVSS Score

9.8
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2021-3177
CWE
CWE-120
Snyk ID
SNYK-UBUNTU1604-PYTHON27-1079210
Disclosed
19 Jan, 2021
Published
29 Jan, 2021