Out-of-Bounds

Affecting pcre3 package, versions *

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

libpcre1 in PCRE 8.40 and libpcre2 in PCRE2 10.23 allow remote attackers to cause a denial of service (segmentation violation for read access, and application crash) by triggering an invalid Unicode property lookup.

References

CVSS Score

7.5
low severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE
CVE-2017-7186
CWE
CWE-119
Snyk ID
SNYK-UBUNTU1604-PCRE3-345435
Disclosed
20 Mar, 2017
Published
20 Mar, 2017