Information Exposure

Affecting libgcrypt20 package, versions <1.6.5-2ubuntu0.5

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Libgcrypt before 1.7.10 and 1.8.x before 1.8.3 allows a memory-cache side-channel attack on ECDSA signatures that can be mitigated through the use of blinding during the signing process in the _gcry_ecc_ecdsa_sign function in cipher/ecc-ecdsa.c, aka the Return Of the Hidden Number Problem or ROHNP. To discover an ECDSA key, the attacker needs access to either the local machine or a different virtual machine on the same physical host.

References

CVSS Score

4.7
low severity
  • Attack Vector
    Local
  • Attack Complexity
    High
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
CVE
CVE-2018-0495
CWE
CWE-203
Snyk ID
SNYK-UBUNTU1604-LIBGCRYPT20-391883
Disclosed
13 Jun, 2018
Published
13 Jun, 2018