Out-of-bounds Write

Affecting glibc package, versions <2.23-0ubuntu11.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

stdlib/canonicalize.c in the GNU C Library (aka glibc or libc6) 2.27 and earlier, when processing very long pathname arguments to the realpath function, could encounter an integer overflow on 32-bit architectures, leading to a stack-based buffer overflow and, potentially, arbitrary code execution.

References

CVSS Score

9.8
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2018-11236
CWE
CWE-190 CWE-787
Snyk ID
SNYK-UBUNTU1604-GLIBC-451230
Disclosed
18 May, 2018
Published
18 May, 2018