Improper Input Validation

Affecting glibc package, versions <2.23-0ubuntu6

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package. See Remediation section below for Ubuntu:16.04 relevant versions.

Stack-based buffer overflow in the getaddrinfo function in sysdeps/posix/getaddrinfo.c in the GNU C Library (aka glibc or libc6) allows remote attackers to cause a denial of service (crash) via vectors involving hostent conversion. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-4458.

Remediation

Upgrade Ubuntu:16.04 glibc to version 2.23-0ubuntu6 or higher.

References

CVSS Score

7.5
low severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE
CVE-2016-3706
CWE
CWE-20
Snyk ID
SNYK-UBUNTU1604-GLIBC-356774
Disclosed
10 Jun, 2016
Published
10 Jun, 2016