Improper Access Control

Affecting glibc package, versions <2.23-0ubuntu6

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package. See Remediation section below for Ubuntu:16.04 relevant versions.

The makecontext function in the GNU C Library (aka glibc or libc6) before 2.25 creates execution contexts incompatible with the unwinder on ARM EABI (32-bit) platforms, which might allow context-dependent attackers to cause a denial of service (hang), as demonstrated by applications compiled using gccgo, related to backtrace generation.

Remediation

Upgrade Ubuntu:16.04 glibc to version 2.23-0ubuntu6 or higher.

References

CVSS Score

7.5
low severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE
CVE-2016-6323
CWE
CWE-284
Snyk ID
SNYK-UBUNTU1604-GLIBC-356485
Disclosed
07 Oct, 2016
Published
07 Oct, 2016