Command Injection

Affecting wkhtmltopdf-binary-edge gem, versions <0.12.5.1

Do your applications use this vulnerable package? Test your applications

Overview

wkhtmltopdf-binary-edge is a package which includes wkthmltopdf binaries for macOS (>= 10.7) and Ubuntu 16 (64bit)

Affected versions of this package are vulnerable to Command Injection. It is possible to passe an untrusted string to the bin/wkhtmltopdf command through the package. This could result in execution or arbitrary commands, or insertion of arbitrary wkhtmltopdf options to change execution flow.

Remediation

Upgrade wkhtmltopdf-binary-edge to version 0.12.5.1 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
  • Exploit maturity
    Unproven
  • Remediation Level
    Official
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:U/RL:O/RC:R
Credit
Akinori MUSHA
CWE
CWE-78
Snyk ID
SNYK-RUBY-WKHTMLTOPDFBINARYEDGE-474621
Disclosed
28 Oct, 2019
Published
30 Oct, 2019