Information Exposure

Affecting spree_api gem, versions >=3.7.0, <3.7.13 || >=4.0.0, <4.0.5 || >=4.1.0, <4.1.12

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

spree_api is a Spree Api module

Affected versions of this package are vulnerable to Information Exposure. An attacker can query the API v2 Order Status endpoint with an empty string passed as an Order token.

Remediation

Upgrade spree_api to version 3.7.13, 4.0.5, 4.1.12 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Credit
Unknown
CVE
CVE-2020-26223
CWE
CWE-200
Snyk ID
SNYK-RUBY-SPREEAPI-1040422
Disclosed
13 Nov, 2020
Published
15 Nov, 2020