Authentication Bypass

Affecting sorcery gem, versions <0.15.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

sorcery is a package that provides common authentication needs such as signing in/out, activating by email and resetting password.

Affected versions of this package are vulnerable to Authentication Bypass. There is a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout.

Remediation

Upgrade sorcery to version 0.15.0 or higher.

References

CVSS Score

8.2
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L
Credit
Ortwin Gentz, FutureTap
CVE
CVE-2020-11052
CWE
CWE-307
Snyk ID
SNYK-RUBY-SORCERY-568682
Disclosed
07 May, 2020
Published
08 May, 2020