Privilege Escalation

Affecting solidus_api gem, versions <1.1.0.pre2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

solidus_api is REST API for the Solidus e-commerce framework.

Affected versions of the package are vulnerable to Privilege Escalation. A lower-level admin can change the email address of a higher-level admin to an email address they have access to, and as a result they will gain access to the admin's permissions.

Remediation

Upgrade solidus_api to version 1.1.0.pre2 or higher.

References

CVSS Score

5.4
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Credit
Andrew Thal
CWE
CWE-264
Snyk ID
SNYK-RUBY-SOLIDUSAPI-20471
Disclosed
06 Oct, 2015
Published
10 Jan, 2018