DNS Hijack Attack

Affecting rubygems-update gem, versions >=2.0.0, <2.0.17 || >=2.2.0, <2.2.5 || >=2.4.0, <2.4.8

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

rubygems-update is an inbuilt rubygem for updating rubygems.

Affected versions of this package are vulnerable to DNS Hijack Attack. It does not validate the hostname when fetching gems or making API requests, which allows remote attackers to redirect requests to arbitrary domains via a crafted DNS SRV record with a domain that is suffixed with the original domain name, aka a DNS hijack attack. NOTE: this vulnerability exists because to an incomplete fix for CVE-2015-3900.

Remediation

Upgrade rubygems-update to version 2.0.17, 2.2.5, 2.4.8 or higher.

References

CVSS Score

4.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Credit
unknown
CVE
CVE-2015-4020
CWE
CWE-20
Snyk ID
SNYK-RUBY-RUBYGEMSUPDATE-472657
Disclosed
08 Jun, 2015
Published
13 Nov, 2019