Improper Verification of Cryptographic Signature

Affecting rubygems-update gem, versions <2.7.6

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

rubygems-update is an inbuilt rubygem for updating rubygems.

Affected versions of this package are vulnerable to Improper Verification of Cryptographic Signature. In package.rb a mis-signed gem could be installed, as the tarball would contain multiple gem signatures.

Remediation

Upgrade rubygems-update to version 2.7.6 or higher.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
Samuel Giddins
CVE
CVE-2018-1000076
CWE
CWE-347
Snyk ID
SNYK-RUBY-RUBYGEMSUPDATE-472654
Disclosed
15 Feb, 2018
Published
13 Nov, 2019