Improper Input Validation

Affecting rubygems-update gem, versions <2.7.6

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

rubygems-update is an inbuilt rubygem for updating rubygems.

Affected versions of this package are vulnerable to Improper Input Validation in ruby gems specification homepage attribute that can result in a malicious gem setting an invalid homepage URL.

Remediation

Upgrade rubygems-update to version 2.7.6 or higher.

References

CVSS Score

5.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Credit
Yasin Soliman
CVE
CVE-2018-1000077
CWE
CWE-20
Snyk ID
SNYK-RUBY-RUBYGEMSUPDATE-472651
Disclosed
13 Mar, 2018
Published
13 Nov, 2019