Man-in-the-Middle (MitM)

Affecting rubygems-update gem, versions <2.6.13

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

rubygems-update is an inbuilt rubygem for updating rubygems.

Affected versions of this package are vulnerable to Man-in-the-Middle (MitM) via a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.

Remediation

Upgrade rubygems-update to version 2.6.13 or higher.

References

CVSS Score

8.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
unknown
CVE
CVE-2017-0902
CWE
CWE-346
Snyk ID
SNYK-RUBY-RUBYGEMSUPDATE-472647
Disclosed
27 Aug, 2017
Published
13 Nov, 2019