Cross-site Request Forgery (CSRF)

Affecting pghero gem, versions <2.7.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

pghero is a performance dashboard for Postgres.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). The Ruby gem is vulnerable with non-session based authentication methods like basic authentication - session-based authentication methods (like Devise's default authentication) are not affected.

Remediation

Upgrade pghero to version 2.7.0 or higher.

References

CVSS Score

7.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    Low
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
Credit
Heiko Webers
CVE
CVE-2020-16253
CWE
CWE-352
Snyk ID
SNYK-RUBY-PGHERO-597398
Disclosed
05 Aug, 2020
Published
05 Aug, 2020