Improper Input Validation

Affecting personnummer gem, versions <3.0.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to Improper Input Validation. The last four digits of the number are not validated.

Remediation

Upgrade personnummer to version 3.0.1 or higher.

References

CVSS Score

5.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Credit
Niklas Sköldmark
CWE
CWE-20
Snyk ID
SNYK-RUBY-PERSONNUMMER-674155
Disclosed
09 Sep, 2020
Published
10 Sep, 2020