Information Exposure

Affecting logstash-core gem, versions <5.6.15 || >=6.0.0, <6.6.1

Do your applications use this vulnerable package? Test your applications

Overview

logstash-core is a scalable log and event management tool.

Affected versions of this package are vulnerable to Information Exposure. If a malformed URL is specified as part of the Logstash configuration, the credentials for the URL could be inadvertently logged as part of the error message.

Remediation

Upgrade logstash-core to version 5.6.15, 6.6.1 or higher.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
Unknown
CVE
CVE-2019-7612
CWE
CWE-200
Snyk ID
SNYK-RUBY-LOGSTASHCORE-460544
Disclosed
25 Mar, 2019
Published
02 Sep, 2019