Improper Certificate Validation

Affecting faye-websocket gem, versions <0.11.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

faye-websocket is a Standards-compliant WebSocket server and client.

Affected versions of this package are vulnerable to Improper Certificate Validation in TLS handshakes. The Faye::WebSocket::Client class uses the EM::Connection#start_tls method in EventMachine to implement the TLS handshake whenever a wss: URL is used for the connection. This method does not implement certificate verification by default, meaning that it does not check that the server presents a valid and trusted TLS certificate for the expected hostname.

Remediation

Upgrade faye-websocket to version 0.11.0 or higher.

References

CVSS Score

8.0
high severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Changed
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
Credit
Unknown
CVE
CVE-2020-15133
CWE
CWE-295
Snyk ID
SNYK-RUBY-FAYEWEBSOCKET-597162
Disclosed
31 Jul, 2020
Published
02 Aug, 2020