Improper Authorization

Affecting actionpack gem, versions >=6.0.0, <6.0.3.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to Improper Authorization. By default, an attacker is able to execute any migrations that are pending for a Rails app running in production mode.

Remediation

Upgrade actionpack to version 6.0.3.2 or higher.

References

CVSS Score

7.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Credit
Unknown
CVE
CVE-2020-8185
CWE
CWE-285
Snyk ID
SNYK-RUBY-ACTIONPACK-572498
Disclosed
17 Jun, 2020
Published
17 Jun, 2020