Improper Authentication

Affecting superdesk-planning package, versions [,2.0.2)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

superdesk-planning is a Superdesk Planning Module

Affected versions of this package are vulnerable to Improper Authentication. Multiple API endpoints were found to be accessible without any authentication.

Remediation

Upgrade superdesk-planning to version 2.0.2 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N/E:U/RL:O/RC:R
Credit
Unknown
CWE
CWE-287
Snyk ID
SNYK-PYTHON-SUPERDESKPLANNING-1090202
Disclosed
01 Apr, 2021
Published
01 Apr, 2021