Cryptographic Issues

Affecting pyhanko package, versions [,0.3.0)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

pyHanko is a Tools for stamping and signing PDF files

Affected versions of this package are vulnerable to Cryptographic Issues via the 'RC4' class, which is not secure.

Remediation

Upgrade pyHanko to version 0.3.0 or higher.

References

CVSS Score

3.1
low severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N
Credit
Matthias Valvekens
CWE
CWE-310
Snyk ID
SNYK-PYTHON-PYHANKO-1300049
Disclosed
04 Jun, 2021
Published
04 Jun, 2021