Weak Password Requirements

Affecting plone package, versions [4.3,4.3.20) || [5.0,5.2.1)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Plone is an user friendly and extensible Content Management System running on top of Python and Zope.

Affected versions of this package are vulnerable to Weak Password Requirements. Some forms that should have checked the strength of a password, did not do this. When registering anonymously, it was checked correctly. But the password reset form or the admin form for adding a new user missed this check.

Remediation

Upgrade Plone to version 4.3.20, 5.2.1 or higher.

References

CVSS Score

2.6
low severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    Low
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N
Credit
Ben Kummer
CVE
CVE-2020-7940
CWE
CWE-521
Snyk ID
SNYK-PYTHON-PLONE-543306
Disclosed
21 Jan, 2020
Published
27 Jan, 2020