Symlink Attack

Affecting numpy package, versions [,1.8.2)

Do your applications use this vulnerable package? Test your applications

Overview

numpy is a package needed for scientific computing with Python.

Affected versions of this package are vulnerable to Symlink Attack. It allows local users to write to arbitrary files via a symlink attack on a temporary file.

Remediation

Upgrade numpy to version 1.8.2 or higher.

References

CVSS Score

5.5
medium severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Credit
Unknown
CVE
CVE-2014-1859
CWE
CWE-59
Snyk ID
SNYK-PYTHON-NUMPY-42067
Disclosed
06 Feb, 2014
Published
25 Feb, 2018