Buffer Overflow

Affecting bsdiff4 package, versions [,1.2.0)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

bsdiff4 is a binary diff and patch using the BSDIFF4-format

Affected versions of this package are vulnerable to Buffer Overflow. A buffer overflow in the patching routine of bsdiff4 allows an attacker to write to heap memory (beyond allocated bounds) via a crafted patch file.

Remediation

Upgrade bsdiff4 to version 1.2.0 or higher.

References

CVSS Score

9.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Credit
Unknown
CVE
CVE-2020-15904
CWE
CWE-119
Snyk ID
SNYK-PYTHON-BSDIFF4-590064
Disclosed
23 Jul, 2020
Published
23 Jul, 2020