Open Redirect

Affecting apache-superset package, versions [,1.1.0)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

apache-superset is a modern, enterprise-ready business intelligence web application.

Affected versions of this package are vulnerable to Open Redirect. Insufficient user input validation of open redirects, the URL shortener functionality allows a malicious user to create a short URL for a dashboard and convince the user to click the link.

Remediation

Upgrade apache-superset to version 1.1.0 or higher.

References

CVSS Score

5.4
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Credit
Gianluca Veltri, Dario Castrogiovanni
CVE
CVE-2021-28125
CWE
CWE-601
Snyk ID
SNYK-PYTHON-APACHESUPERSET-1277187
Disclosed
28 Apr, 2021
Published
28 Apr, 2021