Information Exposure

Affecting apache-airflow package, versions [,1.10.5)

Do your applications use this vulnerable package? Test your applications

Overview

apache-airflow is a platform to programmatically author, schedule, and monitor workflows.

Affected versions of this package are vulnerable to Information Exposure. The databricks operator logs API keys during task instance run. The databricks operator implementation encourages users to put their API key in the connection "extra" field, and its accompanying databricks hook logs that "extra" field in plaintext.

Remediation

Upgrade apache-airflow to version 1.10.5 or higher.

References

CVSS Score

4.2
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    High
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:N/A:N
Credit
zenyui
CWE
CWE-200
Snyk ID
SNYK-PYTHON-APACHEAIRFLOW-451565
Disclosed
09 Jul, 2019
Published
10 Jul, 2019