Race Condition

Affecting ansible package, versions [2.9.0b1,2.9.10) || [,2.8.13)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

ansible is a simple IT automation system.

Affected versions of this package are vulnerable to Race Condition. This flaw refers to the incomplete fix for CVE-2020-1733 insecure temporary directory when running become_user from become directive. This vulnerability is not mitigated fully as there are race conditions from the original flaw could still happen on systems using ACLs and FUSE filesystems.

Remediation

Upgrade ansible to version 2.9.10, 2.8.13 or higher.

References

CVSS Score

5.0
medium severity
  • Attack Vector
    Local
  • Attack Complexity
    High
  • Privileges Required
    Low
  • User Interaction
    Required
  • Scope
    Changed
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L
Credit
Unknown
CVE
CVE-2020-10744
CWE
CWE-377
Snyk ID
SNYK-PYTHON-ANSIBLE-569107
Disclosed
14 May, 2020
Published
15 May, 2020