Directory Traversal

Affecting ansible package, versions [2.7,)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

ansible is a simple IT automation system.

Affected versions of this package are vulnerable to Directory Traversal. An attacker could intercept the module, inject a new path, and then choose a new destination path on the controller node.

Remediation

There is no fixed version for ansible.

References

CVSS Score

7.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Credit
Unknown
CVE
CVE-2020-1735
CWE
CWE-22
Snyk ID
SNYK-PYTHON-ANSIBLE-560368
Disclosed
16 Mar, 2020
Published
16 Mar, 2020