SQL injection

Affecting silverstripe/restfulserver package, versions >=1.0.0, <1.0.9 || >=2.0.0, <2.0.4 || >=2.1.0, <2.1.2

Do your applications use this vulnerable package? Test your applications

Overview

silverstripe/restfulserver is a package that allows you to add a RESTful API to your SilverStripe application.

Affected versions of this package are vulnerable to SQL injection which may allow specially crafted user input to be executed as SQL statements.

Remediation

Upgrade silverstripe/restfulserver to version 1.0.9, 2.0.4, 2.1.2 or higher.

References

CVSS Score

7.4
high severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Credit
Tim Oliver
CVE
CVE-2019-12149
CWE
CWE-89
Snyk ID
SNYK-PHP-SILVERSTRIPERESTFULSERVER-449584
Disclosed
11 Jun, 2019
Published
11 Jun, 2019