Improper Access Control

Affecting silverstripe/graphql package, versions >=3.0.0, <3.5.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

silverstripe/graphql is a GraphQL server for SilverStripe models and other data.

Affected versions of this package are vulnerable to Improper Access Control. Default SilverStripe GraphQL Server (aka silverstripe/graphql) permission checker not inherited by query subclass.

Remediation

Upgrade silverstripe/graphql to version 3.5.2 or higher.

References

CVSS Score

7.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N/E:U/RL:O/RC:R
Credit
Unknown
CVE
CVE-2021-28661
CWE
CWE-284
Snyk ID
SNYK-PHP-SILVERSTRIPEGRAPHQL-1729736
Disclosed
08 Oct, 2021
Published
08 Oct, 2021