Improper Restriction of Excessive Authentication Attempts

Affecting silverstripe/framework package, versions >=3.1.18, <3.1.19 || >=3.2.3, <3.2.4 || >=3.3.1, <3.3.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

silverstripe/framework is a PHP framework forming the base for the SilverStripe CMS.

Affected versions of this package are vulnerable to Improper Restriction of Excessive Authentication Attempts. Default Administrator accounts were not subject to the same brute force protection afforded to other Member accounts. Failed login counts were not logged for default admins resulting in unlimited attempts on the default admin username and password.

Remediation

Upgrade silverstripe/framework to version 3.1.19, 3.2.4, 3.3.2 or higher.

References

CVSS Score

3.7
low severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Credit
Will Rossiter
CWE
CWE-307
Snyk ID
SNYK-PHP-SILVERSTRIPEFRAMEWORK-546519
Disclosed
05 Feb, 2020
Published
05 Feb, 2020