Information Exposure

Affecting shopware/platform package, versions <6.2.3

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

shopware/platform is a Shopware e-commerce core.

Affected versions of this package are vulnerable to Information Exposure. The database password is leaked to an unauthenticated user when a DriverException occurs and verbose error handling is enabled.

Remediation

Upgrade shopware/platform to version 6.2.3 or higher.

References

CVSS Score

7.4
high severity
  • Attack Vector
    Local
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
REQON B.V.
CVE
CVE-2020-13997
CWE
CWE-200
Snyk ID
SNYK-PHP-SHOPWAREPLATFORM-595909
Disclosed
29 Jul, 2020
Published
29 Jul, 2020