SQL Injection

Affecting s-cart/core package, versions <6.3.0.3

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

s-cart/core is a free Laravel e-commerce for business.

Affected versions of this package are vulnerable to SQL Injection via the keyword parameter in /sc_admin/currency.

Remediation

Upgrade s-cart/core to version 6.3.0.3 or higher.

References

CVSS Score

8.6
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
Credit
Huy Nguyen
CWE
CWE-89
Snyk ID
SNYK-PHP-SCARTCORE-1564826
Disclosed
15 Aug, 2021
Published
07 Oct, 2021