Cross-site Request Forgery (CSRF)

Affecting pyrocms/pyrocms package, versions >=0.0.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) via the admin/addons/uninstall/anomaly.module.blocks URI: an arbitrary plugin will be deleted.

Remediation

There is no fixed version for pyrocms/pyrocms.

References

CVSS Score

4.9
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    High
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N/E:P/RL:U/RC:C
Credit
Unknown
CVE
CVE-2020-25263
CWE
CWE-352
Snyk ID
SNYK-PHP-PYROCMSPYROCMS-1016644
Disclosed
08 Oct, 2020
Published
08 Oct, 2020