Improper Authentication

Affecting phpseclib/phpseclib package, versions >=3.0.0, <3.0.7 || <2.0.31

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

phpseclib/phpseclib is a PHP Secure Communications Library - Pure-PHP implementations of RSA, AES, SSH2, SFTP, X.509 etc.

Affected versions of this package are vulnerable to Improper Authentication. It mishandles RSA PKCS#1 v1.5 signature verification.

Remediation

Upgrade phpseclib/phpseclib to version 3.0.7, 2.0.31 or higher.

References

CVSS Score

4.8
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    Low
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N
Credit
Unknown
CVE
CVE-2021-30130
CWE
CWE-287
Snyk ID
SNYK-PHP-PHPSECLIBPHPSECLIB-1243683
Disclosed
07 Apr, 2021
Published
07 Apr, 2021