Information Exposure

Affecting phpmyadmin/phpmyadmin package, versions >=4.0.0, <4.8.4

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

phpmyadmin/phpmyadmin is a web interface for MySQL and MariaDB.

Affected versions of this package are vulnerable to Information Exposure. A malicious user with an access to the phpMyAdmin Configuration Storage tables, could leak the contents of a local file because of an error in the transformation feature.

Remediation

Upgrade phpmyadmin/phpmyadmin to version 4.8.4 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Credit
Daniel Le Gall
CVE
CVE-2018-19968
CWE
CWE-200
Snyk ID
SNYK-PHP-PHPMYADMINPHPMYADMIN-72684
Disclosed
11 Dec, 2018
Published
12 Dec, 2018