Deserialization of Untrusted Data

Affecting phpmyadmin/phpmyadmin package, versions <4.0.10.17 || >=4.4.0.0, <4.4.15.8 || >=4.6.0, <4.6.4

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

phpmyadmin/phpmyadmin is a MySQL web administration too.

Affected versions of this package are vulnerable to Deserialization of Untrusted Data. Some data is passed to the PHP unserialize() function without verification that it's valid serialized data. The unserialization can result in code execution because of the interaction with object instantiation and autoloading.

Remediation

Upgrade phpmyadmin/phpmyadmin to versions 4.0.10.17, 4.4.15.8, 4.6.4 or higher.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
Unknown
CVE
CVE-2016-6620
CWE
CWE-502
Snyk ID
SNYK-PHP-PHPMYADMINPHPMYADMIN-72238
Disclosed
11 Dec, 2016
Published
23 Jul, 2018