Arbitrary Code Execution

Affecting phpmyadmin/phpmyadmin package, versions >=4.8.0, <4.8.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

phpmyadmin/phpmyadmin is a MySQL web administration tool.

Affected versions of this package are vulnerable to Arbitrary Code Execution. An attacker could view and potentially execute files on the server due to a portion of code where pages are redirected and loaded within phpMyAdmin, and an improper test for whitelisted pages.

Remediation

Upgrade phpmyadmin/phpmyadmin to version 4.8.2 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:H/RL:O/RC:C
Credit
Huang Henry
CVE
CVE-2018-12613
CWE
CWE-94
Snyk ID
SNYK-PHP-PHPMYADMINPHPMYADMIN-72215
Disclosed
19 Jun, 2018
Published
28 Jun, 2018