Access Restriction Bypass

Affecting phpmyadmin/phpmyadmin package, versions <4.0.10.20 || >=4.4.0, <4.7.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

phpmyadmin/phpmyadmin is MySQL web administration tool.

Affected versions of this package are vulnerable to Access Restriction Bypass. The restrictions caused by AllowNoPassword = false are bypassed under certain PHP versions. This can allow the login of users who have no password set even if the administrator has set AllowNoPassword to false (which is also the default).

Remediation

Upgrade phpmyadmin/phpmyadmin to versions 4.0.10.20, 4.7.0 or higher.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
Unknown
CVE
CVE-2017-18264
CWE
CWE-284
Snyk ID
SNYK-PHP-PHPMYADMINPHPMYADMIN-70407
Disclosed
28 Mar, 2017
Published
09 May, 2018