Improper Authorization

Affecting phpmyadmin/phpmyadmin package, versions >=4.0.0, <4.0.10.19 || >=4.4.0, <4.4.15.10 || >=4.6.0, <4.6.6

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

phpmyadmin/phpmyadmin is a web interface for MySQL and MariaDB.

Affected versions of this package are vulnerable to Improper Authorization. A user with appropriate permissions is able to connect to an arbitrary MySQL server.

Remediation

Upgrade phpmyadmin/phpmyadmin to version 4.0.10.19, 4.4.15.10, 4.6.6 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Credit
Unknown
CVE
CVE-2017-1000017
CWE
CWE-285
Snyk ID
SNYK-PHP-PHPMYADMINPHPMYADMIN-597472
Disclosed
17 Jul, 2017
Published
06 Aug, 2020