HTTP Header Injection

Affecting phpmyadmin/phpmyadmin package, versions >=4.6.0, <4.6.6

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

phpmyadmin/phpmyadmin is a web interface for MySQL and MariaDB.

Affected versions of this package are vulnerable to HTTP Header Injection. A weakness was discovered where an attacker can inject arbitrary values in to the browser cookies.

Remediation

Upgrade phpmyadmin/phpmyadmin to version 4.6.6 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Credit
Emanuel Bronshtein
CVE
CVE-2017-1000016
CWE
CWE-644
Snyk ID
SNYK-PHP-PHPMYADMINPHPMYADMIN-596502
Disclosed
30 Jul, 2020
Published
30 Jul, 2020