SQL Injection

Affecting phpmyadmin/phpmyadmin package, versions >=4.0.0, <4.9.4 || >=5.0.0, <5.0.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

phpmyadmin/phpmyadmin is a web interface for MySQL and MariaDB.

Affected versions of this package are vulnerable to SQL Injection via the user accounts page. A malicious user could inject custom SQL in place of their own username when creating queries to this page. An attacker must have a valid MySQL account to access the server.

Remediation

Upgrade phpmyadmin/phpmyadmin to version 4.9.4, 5.0.1 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Credit
Unknown
CVE
CVE-2020-5504
CWE
CWE-89
Snyk ID
SNYK-PHP-PHPMYADMINPHPMYADMIN-543282
Disclosed
05 Jan, 2020
Published
26 Jan, 2020