Cross-Site Request Forgery (CSRF)

Affecting phpmyadmin/phpmyadmin package, versions >=0.0.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

phpmyadmin/phpmyadmin is a web interface for MySQL and MariaDB.

Affected versions of this package are vulnerable to Cross-Site Request Forgery (CSRF). It allows deletion of any server in the Setup page.

Remediation

There is no fixed version for phpmyadmin/phpmyadmin.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N/E:P/RL:U
Credit
Manuel Garcia Cardenas
CVE
CVE-2019-12922
CWE
CWE-352
Snyk ID
SNYK-PHP-PHPMYADMINPHPMYADMIN-466990
Disclosed
13 Sep, 2019
Published
15 Sep, 2019