Information Exposure

Affecting moodle/moodle package, versions <3.7.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

moodle/moodle is a learning platform.

Affected versions of this package are vulnerable to Information Exposure of service tokens for users enrolled in the same course.

Remediation

Upgrade moodle/moodle to version 3.7.2 or higher.

References

CVSS Score

8.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N/E:P/RL:O/RC:C
Credit
Unknown
CVE
CVE-2020-1692
CWE
CWE-200
Snyk ID
SNYK-PHP-MOODLEMOODLE-548931
Disclosed
17 Feb, 2020
Published
17 Feb, 2020