Open Redirect

Affecting moodle/moodle package, versions <3.1.18 || >=3.4, <3.4.9 || >=3.5, <3.5.6 || >=3.6, <3.6.4

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

moodle/moodle is a learning platform.

Affected versions of this package are vulnerable to Open Redirect. The form to upload cohorts contained a redirect field, which was not restricted to internal URLs.

Remediation

Upgrade moodle/moodle to version 3.1.18, 3.4.9, 3.5.6, 3.6.4 or higher.

References

CVSS Score

5.4
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N/RL:O
Credit
Unknown
CVE
CVE-2019-10133
CWE
CWE-601
Snyk ID
SNYK-PHP-MOODLEMOODLE-451046
Disclosed
26 Jun, 2019
Published
26 Jun, 2019