Improper Authorization

Affecting moodle/moodle package, versions >=3.5, <3.5.8 || >=3.6, <3.6.6 || >=3.7, <3.7.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

moodle/moodle is a learning platform.

Affected versions of this package are vulnerable to Improper Authorization. Users with the capability to create courses were assigned as a teacher in those courses, regardless of whether they had the capability to be automatically assigned that role.

Remediation

Upgrade moodle/moodle to version 3.5.8, 3.6.6, 3.7.2 or higher.

References

CVSS Score

4.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Credit
Unknown
CVE
CVE-2019-14828
CWE
CWE-285
Snyk ID
SNYK-PHP-MOODLEMOODLE-1088008
Disclosed
21 Mar, 2021
Published
21 Mar, 2021