Open Redirect

Affecting moodle/moodle package, versions >=3.5, <3.5.8 || >=3.6, <3.6.6 || >=3.7, <3.7.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

moodle/moodle is a learning platform.

Affected versions of this package are vulnerable to Open Redirect via the forum subscribe link If the forum's subscription mode was set to "forced subscription".

Remediation

Upgrade moodle/moodle to version 3.5.8, 3.6.6, 3.7.2 or higher.

References

CVSS Score

5.4
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L
Credit
Unknown
CVE
CVE-2019-14831
CWE
CWE-601
Snyk ID
SNYK-PHP-MOODLEMOODLE-1088007
Disclosed
21 Mar, 2021
Published
21 Mar, 2021