Information Disclosure

Affecting moodle/moodle package, versions >=3.10.0, <3.10.1 || >=3.9.0, <3.9.4 || >=3.8.0, <3.8.7

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

moodle/moodle is a learning platform.

Affected versions of this package are vulnerable to Information Disclosure. Insufficient capability checks in some grade related web services meant students were able to view other students grades.

Remediation

Upgrade moodle/moodle to version 3.10.1, 3.9.4, 3.8.7 or higher.

References

CVSS Score

3.7
low severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N/E:U/RL:O/RC:R
Credit
Unknown
CVE
CVE-2021-20184
CWE
CWE-354
Snyk ID
SNYK-PHP-MOODLEMOODLE-1065985
Disclosed
29 Jan, 2021
Published
29 Jan, 2021